2015年08月

2015年08月24日

Acrobat Reader については、おおむね最新版を利用しています。単なるビューアーなので、新しい方がいいじゃん。っていう単純な理由からです。
たまに浮気して Adobe 以外のツールを利用したりもしています。PDF-XChange Viewerとかいいですね。

そしてこの、Acrobat Reader DC ですが、開くとツールパネルウインドウという、めちゃくちゃ邪魔なものが表示されるのです。そして初期の頃では、それを消す方法が分かりませんでした。

最近になって調べたところ、それを消す方法があるようなので、メモ。

参考
Acrobat Reader DCの邪魔なメニューを設定で消せるようになりました

Acrobat Reader DC のメニューから、「編集」 - 「環境設定」 をクリックし、 「文書」の分類から、 「各文書のツールウインドウを開く」のチェックを外します。

これで完了です。

画面がとてもすっきりしました。
当初、このDCにアップグレードしたときに、なんてバカげたことになっているのだろうと、憤りを感じていました。正常な状態になったことをとてもうれしく思います。

※拡張子変更によって回避する方法もあるのですが、やはりメニューから操作するのが自然ですね。





2015年08月23日

まだ使っていません。

いろいろなことを調べていると、forfiles コマンドがあることをしりました。
これは、サイズや拡張子・更新日時を検索して該当するファイルを抽出してくれるものらしいです。

これは、ログのローテーションなどですごく便利ですね。
近々使ってみたいと思います。

参考
[バッチ実践] 第3回 forfiles コマンドの使い方:インフラSEの運用・構築メモ
Windowsで一定期間経過した古いファイルを自動削除するコマンドは?コマンドプロンプト標準コマンドがある:puti se blog

2015年08月22日

僕の働いている会社では、適正判断のテストを受けてもらっています。これらを合否の根拠にすることはありませんが、参考にはしています。
そして、僕自身は今の仕事は、楽しいですし、とても適合していると思います。それは職的なこともそうですし、会社の雰囲気や業務など、幅広くそう思っています。

で、僕が入社するときは、このようなテストはありませんでした。そこで会社にお願いして、適性テストをうけることにしました。

そこで、確かに結果は僕自身をそれなりに表しているようにおもいました。

・性格について
たとえば僕自身は内向的で、よく考えるタイプだという結果がでました。しかし一方で、競争心が高く、積極的な面もあるというのです。これら2つの反する人格を内包しているようなのです。

・コメント
僕自身としては、これらが相反する人格で、一つになり得ないのかは分かりません。しかし僕自身としては、基本的には内向的です。そして一部においては、大変に競争心が高くあります。ただしこれは、自己に向けられることが多く、自己が期待する基準には絶対達成する意識が強く、他者との関わりの中で競争を意識することはほとんどありません。
この場合は、表面上は競争しているように装い、誰もが軽視する他の分野に注力していこうと意識することがほとんどです。

・仕事に対する項目
指導性高い
感情は安定してる
自主性が高い
協調性低い
共感性低い
従順ではない

・コメント
意見や行動をまとめるのが指導性ということのようです。僕は協調は意見を集約することだと思っているので、概ねあっているように思います。
感情も安定するように努力しています。怒らないように。
自主性の高さについては、正直わかりません。が、決断を自分でするということであれば、それはその通りだと思います。

協調の低さは気になりました。対人関係で問題起こしそうですよね・・。一部そういうところもありますが、低いというほどでは無いように思います。
共感性については、共同作業を嫌うということのようです。確かに苦手ではあります。共同作業はできれば常識的な範囲にとどめたいですね。ただし上下関係のある共同作業については、あんまり問題無いように思っています。
従順ではありません。これは確かなことで欠点ですね。もちろん指示には従いますが、一方的な命令には反発します。

・やるき、意欲
達成(困難な目標にも努力し、向上を目指す)
自立(自力で解決したい)
支配(他人を指示するような立場)
物質的(物欲が強い)
上記を重要視する
以下については低い
勤労の意欲(勤労は最小限にしたいと考えている)
親和(和よりも切磋琢磨のような関係を望む)
秩序(ルールに厳しいような環境は向かない)

・コメント
どうとでも、読み手次第で受け取れるような気がします。困難な目標には努力しません。しかし向上は目指します。自力で解決したいです。他人にアドバイスを聞くのはコミュ障の僕には怖いことです。
支配とか指示したいとは思いません。物質的な要望は少ないと思いますが、金銭欲求は非常に強いです。

勤労の意欲は低いと思います。働きたくありません。和はあまり求めません。そういう意味では、達成のそれとはちょっと違いますが、他人と競うような、自分の能力を高められる期待ができる環境の方を好みます。
秩序については、どういうことかわかりません。一貫したルールや法則よりも、不安定で混沌とした状況の方が好きなのは確かです。

以上のことから、僕の仕事の適性は、顧客開発や調査分析のようです。アナリストとかなりたいじゃん!
向いてないのは、営業・在庫管理のような仕事のようです。確かに向いてないなー。ちなみに、過去のアルバイトで経験のあるコールセンターも向いていない業務のようです。確かに苦痛だった!

僕自身の判定結果からは、集中し、没頭するような作業や仕事が向いているようです。一方で、工場のような流れ作業やマニュアルがしっかりしている仕事は向いていないようでした。

なお、これらの判定結果から、僕が今働いている会社には適合しないことが分かりました。

今回の適正検査はとても勉強になりました。

stock_value at 17:56|この記事のURLComments(0)TrackBack(0)仕事。 

2015年08月21日

スペック[ AT-AR3050S ]
定価: 99,800
CPU: MIPS64 800MHz
メモリ: 1G

スペック[ AT-AR3050S ]
定価: 198,000
CPU: MIPS64 1.5GHz
メモリ: 2G

※参考までに、
Yamaha RTX1200 : MIPS 300MHz / Mem:128M
Yamaha RTX1210 : PowerPC 1GHz / Mem:256M
なお、Yamahaルーターはアンチウイルスなどの機能追加ができないため、単純な比較はできません。

他社の機器も調べてみたのですが、CPU見つかりませんでした。

ルーターとしてよりも、UTMとしての製品ですね。
個人的にはルーターとしての利用でもスペックが高いので、(もてあます可能性があるにせよ)選択肢になるのではないかと思います。

すごく単純ではありますが、以下の方法で接続設定を入れました。
※この製品の機能を生かすには、今回の検証用の config だけではなく、IPSやIPレピュテーションを有効にして検証する必要があります。また現在時点ではアンチウイルス制御はできないようでした。
アンチウイルスとアンチスパム機能については、予定のようです。Webフィルタリングはできます。

バイパスモードがとてもおもしろい機能だと思います。

すべてコマンドラインからの設定になります。この辺はまったく変わらないですね。

また、起動時の画面はほとんど linux でした。またログを確認するときも linux のようでした。Webフィルタリングは squid を利用しているようです。

■初期 config
---------------------
awplus#sh running-config
!
service password-encryption
!
no banner motd
!
username manager privilege 15 password 8 $1$bJoVec4D$JwOJGPr7YqoExA0GVasdE0
!
no service ssh
!
service telnet
!
no service http
!
no clock timezone
!
snmp-server
!
aaa authentication enable default local
aaa authentication login default local
!
ip domain-lookup
!
!
!
no service dhcp-server
!
no ip multicast-routing
!
spanning-tree mode rstp
!
interface port1.0.1-1.0.8
switchport
switchport mode access
!
line con 0
line vty 0 4
!
end




■社内環境で検証したときの config
※eth1 で社内LANからのDHCP取得 / クライアントに対して、10.0.0.XX のDHCP配布 / NAT 利用
---------------------

awplus#sh ru
!
service password-encryption
!
no banner motd
!
username manager privilege 15 password 8 $1$bJoVec4D$JwOJGPr7YqoExA0GVasdE0
!
no service ssh
!
service telnet
!
no service http
!
no clock timezone
!
snmp-server
!
aaa authentication enable default local
aaa authentication login default local
!
zone Private
network LAN
ip subnet 10.0.0.0/24
!
zone WAN
network WAN
ip subnet 0.0.0.0/0 interface eth1
!
nat
rule 1 masq any from Private to WAN
enable
!
ip domain-lookup
!
ip dhcp pool Private
network 10.0.0.0 255.255.255.0
range 10.0.0.11 10.0.0.99
dns-server 10.0.0.1
default-router 10.0.0.1
lease 0 24 0
!
!
!
service dhcp-server
!
no ip multicast-routing
!
spanning-tree mode rstp
!
interface port1.0.1-1.0.8
switchport
switchport mode access
!
interface eth1
ip address dhcp
!
interface vlan1
ip address 10.0.0.1/24
!
ntp server ntp.jst.mfeed.ad.jp
!
ip dns forwarding
!
line con 0
line vty 0 4
!
end

2015年08月20日

とりあえずメモ。
・Intelligent Provisioning で Windows2012R2をインストール
・PSPでファームウェアのUpdate。
※ここまでで WBEM でステータスが確認できることを確認。

ファームウェアのバージョンを確認し、HPのサポートサービスに登録されているファームウェアのバージョンと確認。
iLO のバージョンが、若干異なっていたので、手動でダウンロードしインストールしました。
また iLO の Japanese Language Pack をインストールし、日本語を利用できるようにしました。

現在 iLO は DHCP環境でしたが、SNTPを設定し、iLO をリセットしました。これで時刻が同期したことをログから確認しました。

これで、Cドライブやらのパーティションサイズを調整し、新たにDドライブなどを作成。
これで初期セットアップは完了です。

2015年08月19日

SMHは色々と難しいですね。毎回苦労している気がします。
HPのサーバーでは、PSP(ProLiant Support Pack) が用意されています。これにはドライバーやファームウェアがパッケージされており、とても便利なソフトです。(これもインストールには若干クセがありますが・・)

今回僕は、 Intelligent Provisioning を実行し、Windows2012をインストールしました。OSが起動してからPSPを実行し、自動でドライバー類を当てたのです。


しかしこの状態では、SMHのインストールは行われましたが、Agentは一切インストールされませんでした。そのためSMHを実行しても何も表示されないのです。

まずSMHでは、SNMPをデータソースにする場合には、Insight マネジメント エージェント(IMA) のインストールが必要です。また、WBEMを利用する場合には、Insight Management WBEM Providers のインストールが必要です。そしてこれらのファイルは、PSPを実行し、手動でソフトを選択することによってインストールが可能でした。

※またIMAを利用する場合には、Windows側で SNMP 機能をインストールし、設定しないと利用できません。

とりあえずこのことに気づくことができたので、それからはスムーズでした。
HP ProLiant Gen8 シリーズ - Gen 8 サーバーのハードウェア監視方法について

2015年08月18日

会社の人のPCで、電源が入らなくなりました。
突然シャットダウンした。そのように言うのです。

話を聞く限りでは、電源ユニットの故障のようでした。

社内にある電源ユニットをいくつか交換して試したのですが、状況は一切かわりませんでした。
相変わらず電源が入らないのです。

そこで、違うPCを用意して、電源ユニットのチェック。やはり電源ユニットは死んでいました。
しかし正常な電源ユニットを故障PCに接続しても、やはり起動しないのです。

結局結論としては、マザーボードと電源ユニットが同時に死んだのでは無いかと思われる事象でした。
あまり時間もかけられないので、とりあえずはここまでの調査で終わらせてしまい、新たなPCを利用してもらうことになりました。

電源をチェックするパーツがあるようですね。


電源・電圧チェック 電源テスター Power Supply Tester 3